We are continuing to actively follow up on the situation with our partner AWS and will share additional updates as soon as we receive more information.
Posted Mar 16, 2026 - 06:45 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 03, 2026 - 12:33 CET
Update
We remain in close coordination with our cloud providers to gain full visibility into the current situation. We will provide timely updates as soon as additional information becomes available.
Posted Mar 03, 2026 - 12:07 CET
Identified
Due to the current geopolitical situation in the Middle East, some of our services operating in this region are currently impacted.
Several services are temporarily unavailable as certain cloud data centers in the affected area are experiencing connectivity and power disruptions.
At this stage, we do not yet have a confirmed timeline for full service restoration. Our teams are actively monitoring the situation and coordinating with our cloud infrastructure providers.
We will provide further updates as soon as additional information becomes available.
We appreciate your understanding and remain fully mobilized to restore normal operations as quickly as possible.
Posted Mar 02, 2026 - 12:01 CET
This incident affects: Middle East (Call Recorder - Teams, Call Recorder - Webex Calling, Call Recorder - Webex Contact Center).