Microsoft Teams Direct Routing Instability Following Microsoft Certificate Authority Rotation (June 30 – July 2, 2026)

Incident Report for Service Status Page

Resolved

The service has been confirmed stable
Posted Jul 02, 2026 - 18:15 CEST

Monitoring

On June 30, 2026 at 09:00 UTC, Microsoft began a planned, multi-day rotation of the TLS certificates presented by its Teams Direct Routing SIP endpoints, moving them to a new Certificate Authority chain on a staged, per-geography basis. During the rotation window, Teams endpoints presented a mix of legacy and new certificate chains.

Following the start of this activity, TLS sessions between our SBC infrastructure and the Teams SIP endpoints became progressively unstable, degrading Direct Routing signaling for a subset of trunks. Consistent with the staged nature of the Microsoft rotation, not all customers were impacted.

Full restoration required realigning the SBC certificate trust configuration to Microsoft's updated Certificate Authority set and performing a complete reset of all TLS connections towards Microsoft Teams. Service is stable now.
Posted Jul 02, 2026 - 15:16 CEST
This incident affected: Europe (SIP Media Edge).